Foo requires PHP 5.3 or higher. You’re still on 5.2.17.